]> de.git.xonotic.org Git - voretournament/voretournament.git/blobdiff - misc/source/gmqcc-src/distro/gentoo/gmqcc-0.3.0.ebuild
By fteqcc, hello gmqcc
[voretournament/voretournament.git] / misc / source / gmqcc-src / distro / gentoo / gmqcc-0.3.0.ebuild
diff --git a/misc/source/gmqcc-src/distro/gentoo/gmqcc-0.3.0.ebuild b/misc/source/gmqcc-src/distro/gentoo/gmqcc-0.3.0.ebuild
new file mode 100644 (file)
index 0000000..28630d3
--- /dev/null
@@ -0,0 +1,20 @@
+EAPI=5
+
+DESCRIPTION="An Improved Quake C Compiler"
+HOMEPAGE="http://graphitemaster.github.com/gmqcc/"
+SRC_URI="https://github.com/graphitemaster/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+       sed -i -e "s:-Werror ::" Makefile || die
+}
+
+src_install() {
+       emake install PREFIX="${D}/usr"
+       dodoc README
+}