fix a stupid bug in shader parsing (it was ignoring passes when not transparent)
authorhavoc <havoc@d7cf8633-e32d-0410-b094-e92efae38249>
Wed, 24 Aug 2005 18:51:16 +0000 (18:51 +0000)
committerhavoc <havoc@d7cf8633-e32d-0410-b094-e92efae38249>
Wed, 24 Aug 2005 18:51:16 +0000 (18:51 +0000)
git-svn-id: svn://svn.icculus.org/twilight/trunk/darkplaces@5655 d7cf8633-e32d-0410-b094-e92efae38249

model_brush.c

index 7957425..253edee 100644 (file)
@@ -3710,9 +3710,9 @@ static void Mod_Q3BSP_LoadTextures(lump_t *l)
                                                                                        Con_Printf(" %s", parameter[j]);
                                                                                Con_Print("\n");
                                                                        }
-                                                                       if (passnumber == 0 && numparameters >= 1 && (flags & Q3SURFACEPARM_TRANS))
+                                                                       if (passnumber == 0 && numparameters >= 1)
                                                                        {
-                                                                               if (!strcasecmp(parameter[0], "blendfunc"))
+                                                                               if (!strcasecmp(parameter[0], "blendfunc") && (flags & Q3SURFACEPARM_TRANS))
                                                                                {
                                                                                        if (numparameters == 2 && !strcasecmp(parameter[1], "add"))
                                                                                                flags2 |= Q3TEXTUREFLAG_ADDITIVE;