]> de.git.xonotic.org Git - xonotic/gmqcc.git/blob - distro/arch/git/PKGBUILD
bumping arch/release PKGBUILD to 0.2.2
[xonotic/gmqcc.git] / distro / arch / git / PKGBUILD
1 pkgname=gmqcc
2 pkgver=20121226
3 pkgrel=1
4 pkgdesc="An Improved Quake C Compiler"
5 arch=('i686' 'x86_64')
6 depends=('glibc')
7 url="https://github.com/graphitemaster/gmqcc.git"
8 license=('MIT')
9
10 _gitroot="git://github.com/graphitemaster/gmqcc.git"
11 _gitname="gmqcc"
12
13 build() {
14         cd $srcdir
15         msg "Connecting to the GIT server..."
16         if [[ -d $srcdir/$_gitname ]] ; then
17                 cd $_gitname
18                 msg "Removing build files..."
19                 git clean -dfx
20                 msg "Updating..."
21                 git pull --no-tags
22                 msg "The local files are updated."
23         else
24                 msg "Cloning..."
25                 git clone $_gitroot $_gitname --depth 1
26                 msg "Clone done."
27         fi
28
29         msg "Starting compilation..."
30         cd "$srcdir"/"$_gitname"
31
32         msg "Compiling..."
33         make
34 }
35
36 check() {
37         cd "$srcdir"/"$_gitname"
38         make check
39 }
40
41 package() {
42         cd "$srcdir"/"$_gitname"
43         msg "Compiling and installing to pkgdir this time..."
44         make install DESTDIR=$pkgdir PREFIX=/usr
45         msg "Compiling done."
46
47         install -D LICENSE ${pkgdir}/usr/share/licenses/gmqcc/LICENSE
48 }