]> de.git.xonotic.org Git - xonotic/gmqcc.git/blob - gmqcc.spec
Update to 0.3.0 (improved new package: gmqpak)
[xonotic/gmqcc.git] / gmqcc.spec
1 Name:           gmqcc
2 Version:        0.3.0
3 Release:        1%{?dist}
4 Summary:        Improved Quake C Compiler
5 License:        MIT
6 URL:            http://graphitemaster.github.io/gmqcc/
7 Source0:        https://github.com/graphitemaster/%{name}/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
8
9 %description
10 Modern written-from-scratch compiler for the QuakeC language with
11 support for many common features found in other QC compilers.
12
13 %package -n qcvm
14 Summary:        Standalone QuakeC VM binary executor
15
16 %description -n qcvm
17 Executor for QuakeC VM binary files created using a QC compiler such
18 as gmqcc or fteqcc. It provides a small set of built-in functions, and
19 by default executes the main function if there is one. Some options
20 useful for debugging are available as well.
21
22 %package -n gmqpak
23 Summary:        Standalone Quake PAK file utility
24
25 %description -n gmqpak
26 Standalone Quake PAK file utility supporting the extraction of files,
27 directories, or whole PAKs, as well as the opposite (creation of PAK files).
28
29 %prep
30 %setup -q
31 echo '#!/bin/sh' > ./configure
32 chmod +x ./configure
33
34 %build
35 %configure
36 make %{?_smp_mflags}
37
38 %install
39 %make_install PREFIX=%{_prefix}
40
41 %check
42 make check
43
44 %files
45 %doc LICENSE README AUTHORS CHANGES TODO
46 %doc gmqcc.ini.example
47 %{_mandir}/man1/gmqcc.1.gz
48 %{_bindir}/gmqcc
49
50 %files -n qcvm
51 %doc LICENSE README AUTHORS CHANGES TODO
52 %{_mandir}/man1/qcvm.1.gz
53 %{_bindir}/qcvm
54
55 %files -n gmqpak
56 %doc LICENSE README AUTHORS CHANGES TODO
57 %{_mandir}/man1/gmqpak.1.gz
58 %{_bindir}/gmqpak
59
60 %changelog
61 * Fri Sep 20 2013 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.3.0-1
62 - Update to 0.3.0 (improved new package: gmqpak)
63
64 * Sat Jul 27 2013 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.2.9-1
65 - Initial release