Adding patch_seam q3map2 regression test. Probably not fixable, but good to
[xonotic/netradiant.git] / COMPILING
index 5fcf59d64f15584d4c937e6a12e4242206da7396..902dd59533f7dfc571fc7e384a4116ac83a149ec 100644 (file)
--- a/COMPILING
+++ b/COMPILING
@@ -1,5 +1,5 @@
-developer documentation for GtkRadiant 1.5.0
-============================================
+developer documentation for GtkRadiant 1.6.0 (Zeroradiant)
+==========================================================
 
 getting the source
 ==================
@@ -13,17 +13,21 @@ The subversion client can be obtained from the Subversion site.
 To get a copy of the source using the commandline Subversion client:
   Change the current directory to the desired location for the source.
   svn checkout https://zerowing.idsoftware.com/svn/radiant/GtkRadiant/trunk/ ./GtkRadiant
-  svn checkout https://zerowing.idsoftware.com/svn/radiant.gamepacks/Q3Pack/trunk/ ./GtkRadiant/games/Q3Pack
-
 
+Download the desired game packs:
+  cd ./GtkRadiant/install/installs
+  svn checkout https://zerowing.idsoftware.com/svn/radiant.gamepacks/Q3Pack/trunk/ ./Q3Pack
+  svn checkout https://zerowing.idsoftware.com/svn/radiant.gamepacks/UFOAIPack/trunk/ ./UFOAIPack
+  svn checkout https://zerowing.idsoftware.com/svn/radiant.gamepacks/TremulousPack/trunk/ ./TremulousPack
 
 Linux/OSX(using X-windows)
 ==========================
 
 environment:
-- gcc3 (preferably)
-- scons = 0.96 (radiant is built with scons rather than make)
-- python >= 2.3.0 (scons requires python, some build steps use python)
+- gcc >= version 3.1 (preferably)
+- scons >= 0.96 (radiant is built with scons rather than make)
+- python >= 2.3.0, (scons requires python, some build steps use python)
+- svn >= 1.1 (some build steps use svn)
 
 dependencies:
 - gtk+ >= 2.4.0 (requires glib, atk, pango, iconv, etc)
@@ -31,43 +35,36 @@ dependencies:
 - libxml2 >= 2.0.0
 - zlib >= 1.2.0 (for archivezip module)
 - libpng >= 1.2.0 (for imagepng module)
-- libmhash = 0.9.0 (for q3map2)
 
 build:
-Execute 'scons SETUP=0' in the directory containing SConscript
+Execute 'scons' in the directory containing SConscript
 
 install:
-run './GtkRadiant/install.py'
+run 'python ./GtkRadiant/install.py'
 note - this script should be run after each time you update from svn
 
 run:
 Execute './GtkRadiant/install/radiant.x86' (or './GtkRadiant/install/radiant.ppc' on osx)
 
 
-
-Win32 (2000 or XP)
+Win32 (2000, XP or Vista)
 ==================
 
 environment:
-- visual studio .net 2003
-- microsoft c++ compiler 7.1 (comes with vs.net 2003)
-- python 2.3.0 or later
+- visual studio 2005
+- python 2.3.0 or later (some build steps use python)
+- subversion 1.1 or later (some build steps use svn)
 
 dependencies are prepackaged archives, extract them to the directory above GtkRadiant.sln:
-- http://zerowing.idsoftware.com/files/radiant/developer/1.5/gtk2-2.4.14.zip (gtk-wimp, gtkglext, gtk, glib, atk, pango, iconv etc)
-- http://zerowing.idsoftware.com/files/radiant/developer/1.5/libxml2-2.6.2.zip
-- http://zerowing.idsoftware.com/files/radiant/developer/1.5/STLport-4.6.2.zip
-- http://zerowing.idsoftware.com/files/radiant/developer/1.5/zlib1-1.2.1.zip (for archivezip module)
-- http://zerowing.idsoftware.com/files/radiant/developer/1.5/libpng-1.2.5.zip (for imagepng module)
-- http://zerowing.idsoftware.com/files/radiant/developer/1.5/mhash-0.9.1.zip (for q3map2)
+- http://zerowing.idsoftware.com/files/radiant/developer/1.5/gtkradiant-1.5-dependencies-1.0.zip
 
 build:
 Open GtkRadiant.sln.
-In tools > options > projects > VC++ Directories > executables, add the path to python.exe (e.g. c:\python23\)
+In tools > options > projects > VC++ Directories > executables, add the paths to python.exe (e.g. c:\python23\) and svn.exe (e.g. c:\svn\)
 Hit 'Build > Build Solution' (F7)
 
 install:
-run './GtkRadiant/install.py'
+run 'python ./GtkRadiant/install.py'
 note - this script should be run after each time you update from svn
 
 run: