]> de.git.xonotic.org Git - xonotic/netradiant.git/blobdiff - bundle/CMakeLists.txt
bundle: store dll in lib subdirectory, bundle all of them at once
[xonotic/netradiant.git] / bundle / CMakeLists.txt
diff --git a/bundle/CMakeLists.txt b/bundle/CMakeLists.txt
new file mode 100644 (file)
index 0000000..1cb5a22
--- /dev/null
@@ -0,0 +1,18 @@
+if (WIN32)
+    set(BUNDLE_OS_NAME "windows")
+else ()
+    set(BUNDLE_OS_NAME "unsupported")
+endif ()
+
+add_custom_target(bundle ALL
+    COMMAND "${PROJECT_SOURCE_DIR}/library-bundler"
+    "${BUNDLE_OS_NAME}" "${PROJECT_BINARY_DIR}"
+    VERBATIM
+    COMMENT "Bundling libraries"
+)
+
+install(DIRECTORY
+    ${PROJECT_BINARY_DIR}/lib
+    ${PROJECT_BINARY_DIR}/share
+    DESTINATION ${CMAKE_INSTALL_PREFIX}
+)