Add a requirements file.
[xonotic/xonstat.git] / setup.py
1 from setuptools import setup, find_packages
2
3 requires = [
4     'pyramid',
5     'SQLAlchemy',
6     'transaction',
7     'repoze.tm2>=1.0b1', # default_commit_veto
8     'zope.sqlalchemy',
9     'WebError',
10     'sqlahelper',
11     'webhelpers',
12     'psycopg2',
13     'pyramid_beaker',
14     'pyramid_mako',
15     'waitress',
16 ]
17
18 setup(
19     name='XonStat',
20     version='1.0',
21     description='XonStat',
22     long_description='XonStat: The statistics web application for Xonotic',
23     classifiers=[
24         "Programming Language :: Python",
25         "Framework :: Pyramid",
26         "Topic :: Internet :: WWW/HTTP",
27         "Topic :: Internet :: WWW/HTTP :: WSGI :: Application",
28     ],
29     author='Ant Zucaro',
30     author_email='azucaro@gmail.com',
31     url='http://stats.xonotic.org',
32     keywords='web wsgi pylons pyramid',
33     packages=find_packages(),
34     include_package_data=True,
35     zip_safe=False,
36     install_requires=requires
37 )
38