]> de.git.xonotic.org Git - xonotic/netradiant.git/blobdiff - radiant/CMakeLists.txt
do not remember game was switched when selected at startup, <3 @Garux
[xonotic/netradiant.git] / radiant / CMakeLists.txt
index 1e2040daa9a272ef7792948320b3ea24e99a0e9b..93fedea428a461f615136ae3964c7d2e9e5f0238 100644 (file)
@@ -90,17 +90,18 @@ set(RADIANTLIST
     xmlstuff.cpp xmlstuff.h
     xywindow.cpp xywindow.h
 )
+
 if (WIN32)
     list(APPEND RADIANTLIST multimon.cpp multimon.h)
-endif()
+endif ()
 
-radiant_tool(radiant WIN32 radiant.rc ${RADIANTLIST})
-add_dependencies(radiant modules)
-target_link_libraries(radiant
+radiant_tool(${RADIANT_BASENAME} WIN32 radiant.rc ${RADIANTLIST})
+add_dependencies(${RADIANT_BASENAME} modules)
+target_link_libraries(${RADIANT_BASENAME}
     ${CMAKE_DL_LIBS}
     ${LIBXML2_LIBRARIES}
     ${OPENGL_gl_LIBRARY}
-    ${${GTK_NS}_LIBRARIES}
+    ${GTK${GTK_TARGET}_LIBRARIES}
     ${GTKGL_LIBRARIES}
     includes
     cmdlib
@@ -126,8 +127,9 @@ target_link_libraries(radiant
     uilib
     xmllib
 )
+
 if (X11_LIBRARIES)
-    target_link_libraries(radiant ${X11_LIBRARIES})
+    target_link_libraries(${RADIANT_BASENAME} ${X11_LIBRARIES})
 endif ()
 
-copy_dlls(radiant)
+copy_dlls(${RADIANT_BASENAME})