]> de.git.xonotic.org Git - xonotic/netradiant.git/blobdiff - radiant/CMakeLists.txt
radiant: build netradiant as non-PIE binary on Linux to workaround a mime-type bug
[xonotic/netradiant.git] / radiant / CMakeLists.txt
index 93fedea428a461f615136ae3964c7d2e9e5f0238..aa52ef32ed842f2a75f83a7b62468f7f56a5b7f9 100644 (file)
@@ -132,4 +132,15 @@ if (X11_LIBRARIES)
     target_link_libraries(${RADIANT_BASENAME} ${X11_LIBRARIES})
 endif ()
 
+# PIE executables were wrongly recognized as shared libraries on Linux
+# because of a mistake in the mime-type library.
+# Because of that it was not possible to launch such executables from
+# the file browser.
+# While the problem is fixed upstream, most distributions still ship
+# with a faulty mime-type library and may do for a long time.
+# See: https://gitlab.freedesktop.org/xdg/shared-mime-info/-/issues/11
+if ("${CMAKE_SYSTEM_NAME}" STREQUAL "Linux")
+    target_link_libraries(${RADIANT_BASENAME} -no-pie)
+endif()
+
 copy_dlls(${RADIANT_BASENAME})