]> de.git.xonotic.org Git - xonotic/netradiant.git/blobdiff - tools/CMakeLists.txt
q3map2/help: list supported games
[xonotic/netradiant.git] / tools / CMakeLists.txt
index 94cbbe5bd19c60071fc0b6c6187c3bcf5168e4b8..6e30389c35107adcb53c9e16d403b8fc51868aa2 100644 (file)
@@ -1,13 +1,10 @@
 set(CMAKE_RUNTIME_OUTPUT_DIRECTORY "${PROJECT_BINARY_DIR}")
 
-macro(radiant_tool name)
-    add_executable(${name} ${ARGN})
-    if (NOT (CMAKE_EXECUTABLE_SUFFIX STREQUAL RADIANT_EXECUTABLE))
-        add_custom_command(TARGET ${name} POST_BUILD
-                COMMAND ln -f -s "$<TARGET_FILE_NAME:${name}>" "${PROJECT_BINARY_DIR}/${name}.${RADIANT_EXECUTABLE}"
-                VERBATIM
-                )
-    endif ()
-endmacro()
-
+add_subdirectory(quake2)
+add_subdirectory(heretic2)
 add_subdirectory(quake3)
+
+add_custom_target(tools)
+add_dependencies(tools quake2 heretic2 quake3)
+
+add_subdirectory(unvanquished)