]> de.git.xonotic.org Git - xonotic/netradiant.git/blobdiff - tools/quake3/CMakeLists.txt
cmake: do not use WIN32 for console tools
[xonotic/netradiant.git] / tools / quake3 / CMakeLists.txt
index d2d3ae2b342edfc4d62fa43e7e9318e84068c551..41af91c51da4117a8c6685c92f3a89d75e513803 100644 (file)
@@ -60,7 +60,7 @@ set(q3map2_games
         )
 
 radiant_tool(q3map2
-        WIN32 q3map2/q3map2.rc
+        q3map2/q3map2.rc
 
         common/cmdlib.c common/cmdlib.h
         common/imagelib.c common/imagelib.h
@@ -127,8 +127,6 @@ radiant_tool(q3map2
         q3map2/writebsp.c
         )
 
-console_app(q3map2)
-
 if (BUILD_CRUNCH)
         set(OPTIONAL_IMAGE_LIBRARIES crnrgba)
         set(OPTIONAL_IMAGE_DEFINES BUILD_CRUNCH=1)
@@ -157,7 +155,7 @@ target_link_libraries(q3map2
         )
 
 radiant_tool(q3data
-        WIN32 q3data/q3data.rc
+        q3data/q3data.rc
 
         common/aselib.c common/aselib.h
         common/bspfile.c common/bspfile.h
@@ -181,8 +179,6 @@ radiant_tool(q3data
         q3data/video.c
         )
 
-console_app(q3data)
-
 target_link_libraries(q3data
         ${GLIB_LIBRARIES}
         ${LIBXML2_LIBRARIES}