]> de.git.xonotic.org Git - xonotic/netradiant.git/blobdiff - tools/quake3/CMakeLists.txt
cmake: make tools target the console subsystem on Windows
[xonotic/netradiant.git] / tools / quake3 / CMakeLists.txt
index 7ba643bfdf7529f233845cecba214901fab3ca63..d2d3ae2b342edfc4d62fa43e7e9318e84068c551 100644 (file)
@@ -127,6 +127,8 @@ radiant_tool(q3map2
         q3map2/writebsp.c
         )
 
+console_app(q3map2)
+
 if (BUILD_CRUNCH)
         set(OPTIONAL_IMAGE_LIBRARIES crnrgba)
         set(OPTIONAL_IMAGE_DEFINES BUILD_CRUNCH=1)
@@ -179,6 +181,8 @@ radiant_tool(q3data
         q3data/video.c
         )
 
+console_app(q3data)
+
 target_link_libraries(q3data
         ${GLIB_LIBRARIES}
         ${LIBXML2_LIBRARIES}