]> de.git.xonotic.org Git - xonotic/netradiant.git/blobdiff - tools/quake3/CMakeLists.txt
quake3/help: move away from termcap
[xonotic/netradiant.git] / tools / quake3 / CMakeLists.txt
index 82bc897d0ff3bd7a9d6215684ffee3bcbd27ccc4..638d867c4969dd48053d2e6454ec00fac739f98c 100644 (file)
@@ -23,9 +23,6 @@ include_directories(${WEBP_INCLUDE_DIR})
 find_package(LibXml2 REQUIRED)
 include_directories(${LIBXML2_INCLUDE_DIR})
 
-find_package(ZLIB REQUIRED)
-include_directories(${ZLIB_INCLUDE_DIRS})
-
 find_package(Minizip REQUIRED)
 include_directories(${Minizip_INCLUDE_DIRS})
 
@@ -39,7 +36,9 @@ set(q3map2_games
         q3map2/game_ja.h
         q3map2/game_jk2.h
         q3map2/game_nexuiz.h
+        q3map2/game_oa.h
         q3map2/game_prophecy.h
+        q3map2/game_q3rally.h
         q3map2/game_qfusion.h
         q3map2/game_quake3.h
         q3map2/game_quakelive.h
@@ -49,8 +48,11 @@ set(q3map2_games
         q3map2/game_tenebrae.h
         q3map2/game_tremulous.h
         q3map2/game_unvanquished.h
+        q3map2/game_warfork.h
+        q3map2/game_warsow.h
         q3map2/game_wolf.h
         q3map2/game_wolfet.h
+        q3map2/game_wop.h
         q3map2/game_xonotic.h
         )
 
@@ -139,7 +141,6 @@ target_link_libraries(q3map2
         ${WEBP_LIBRARIES}
         ${LIBXML2_LIBRARIES}
         ${Minizip_LIBRARIES}
-        ${ZLIB_LIBRARIES}
         ${OPTIONAL_IMAGE_LIBRARIES}
         ddslib
         etclib
@@ -178,7 +179,6 @@ target_link_libraries(q3data
         ${GLIB_LIBRARIES}
         ${LIBXML2_LIBRARIES}
         ${Minizip_LIBRARIES}
-        ${ZLIB_LIBRARIES}
         filematch
         etclib
         l_net
@@ -192,3 +192,5 @@ if (UNIX)
     target_link_libraries(q3map2 pthread m)
     target_link_libraries(q3data m)
 endif ()
+
+target_link_libraries(q3map2)