]> de.git.xonotic.org Git - xonotic/netradiant.git/blobdiff - tools/quake3/CMakeLists.txt
quake3/help: move away from termcap
[xonotic/netradiant.git] / tools / quake3 / CMakeLists.txt
index e0bb8989138233bfe67714c52bf336e50fe05fcd..638d867c4969dd48053d2e6454ec00fac739f98c 100644 (file)
@@ -1,16 +1,11 @@
 include_directories(BEFORE common)
 
 set(Q3MAP_VERSION 2.5.17n)
-find_package(Git REQUIRED)
-execute_process(
-        COMMAND ${GIT_EXECUTABLE} rev-parse --short HEAD
-        WORKING_DIRECTORY ${PROJECT_SOURCE_DIR}
-        OUTPUT_VARIABLE GIT_VERSION
-        OUTPUT_STRIP_TRAILING_WHITESPACE
-)
+
 if (GIT_VERSION)
     set(Q3MAP_VERSION "${Q3MAP_VERSION}-git-${GIT_VERSION}")
 endif ()
+
 add_definitions(-DQ3MAP_VERSION="${Q3MAP_VERSION}")
 
 find_package(GLIB REQUIRED)
@@ -28,9 +23,6 @@ include_directories(${WEBP_INCLUDE_DIR})
 find_package(LibXml2 REQUIRED)
 include_directories(${LIBXML2_INCLUDE_DIR})
 
-find_package(ZLIB REQUIRED)
-include_directories(${ZLIB_INCLUDE_DIRS})
-
 find_package(Minizip REQUIRED)
 include_directories(${Minizip_INCLUDE_DIRS})
 
@@ -44,22 +36,28 @@ set(q3map2_games
         q3map2/game_ja.h
         q3map2/game_jk2.h
         q3map2/game_nexuiz.h
+        q3map2/game_oa.h
         q3map2/game_prophecy.h
+        q3map2/game_q3rally.h
         q3map2/game_qfusion.h
         q3map2/game_quake3.h
         q3map2/game_quakelive.h
         q3map2/game_reaction.h
+        q3map2/game_smokinguns.h
         q3map2/game_sof2.h
         q3map2/game_tenebrae.h
         q3map2/game_tremulous.h
         q3map2/game_unvanquished.h
+        q3map2/game_warfork.h
+        q3map2/game_warsow.h
         q3map2/game_wolf.h
         q3map2/game_wolfet.h
+        q3map2/game_wop.h
         q3map2/game_xonotic.h
         )
 
 radiant_tool(q3map2
-        WIN32 q3map2/q3map2.rc
+        q3map2/q3map2.rc
 
         common/cmdlib.c common/cmdlib.h
         common/imagelib.c common/imagelib.h
@@ -143,7 +141,6 @@ target_link_libraries(q3map2
         ${WEBP_LIBRARIES}
         ${LIBXML2_LIBRARIES}
         ${Minizip_LIBRARIES}
-        ${ZLIB_LIBRARIES}
         ${OPTIONAL_IMAGE_LIBRARIES}
         ddslib
         etclib
@@ -154,7 +151,7 @@ target_link_libraries(q3map2
         )
 
 radiant_tool(q3data
-        WIN32 q3data/q3data.rc
+        q3data/q3data.rc
 
         common/aselib.c common/aselib.h
         common/bspfile.c common/bspfile.h
@@ -182,7 +179,6 @@ target_link_libraries(q3data
         ${GLIB_LIBRARIES}
         ${LIBXML2_LIBRARIES}
         ${Minizip_LIBRARIES}
-        ${ZLIB_LIBRARIES}
         filematch
         etclib
         l_net
@@ -196,3 +192,5 @@ if (UNIX)
     target_link_libraries(q3map2 pthread m)
     target_link_libraries(q3data m)
 endif ()
+
+target_link_libraries(q3map2)