Increase Xonotic version to 0.8.5
[xonotic/xonotic-data.pk3dir.git] / xonotic-common.cfg
index 05670d56ca19a54a18a3ad38e46664a1b9ca1d45..dc9f1f080a74ddfa82e0dadc2208ab6d82cd7eea 100644 (file)
@@ -7,7 +7,8 @@
 
 // Xonotic version (formatted for machines)
 // used to determine if a client version is compatible
-// this doesn't have to be bumped with every release
+// general policy: previous release has "best effort" support, older releases are unsupported,
+// but gameversion_min doesn't have to be bumped with every release
 // bump when clients become incompatible or any other perfectly good reason
 // (e.g. game data incompatibility, engine version incompatibility, etc
 // note: this automatically filters the server browser, clients of the new
@@ -17,9 +18,9 @@
 // e.g. Xonotic 1.5.1 RC1 will be 15101
 set g_xonoticversion git "Xonotic version (formatted for humans)"
 
-gameversion 802 // 0.8.2
-gameversion_min 0 // git builds see all versions
-gameversion_max 65535 // git builds see all versions
+gameversion 805       // 0.8.5
+gameversion_min 802   // 0.8.2 is the previous release
+gameversion_max 65535 // future versions should nag players to update
 
 // compatibility guideline:
 //   version a.b.c   = a0b0c