ripped out vertex array function lookup, require OpenGL 1.2.x instead.
authorlordhavoc <lordhavoc@d7cf8633-e32d-0410-b094-e92efae38249>
Tue, 23 Jan 2001 00:10:51 +0000 (00:10 +0000)
committerlordhavoc <lordhavoc@d7cf8633-e32d-0410-b094-e92efae38249>
Tue, 23 Jan 2001 00:10:51 +0000 (00:10 +0000)
git-svn-id: svn://svn.icculus.org/twilight/trunk/darkplaces@131 d7cf8633-e32d-0410-b094-e92efae38249

vid_glx.c

index 7e0f945..4a069e1 100644 (file)
--- a/vid_glx.c
+++ b/vid_glx.c
@@ -469,6 +469,7 @@ void InitSig(void)
        signal(SIGTERM, signal_handler);
 }
 
+/*
 void (*qglVertexPointer)(GLint size, GLenum type, GLsizei stride, const GLvoid *ptr);
 void (*qglColorPointer)(GLint size, GLenum type, GLsizei stride, const GLvoid *ptr);
 void (*qglTexCoordPointer)(GLint size, GLenum type, GLsizei stride, const GLvoid *ptr);
@@ -509,6 +510,13 @@ void VID_CheckVertexArrays (void)
        Con_Printf("...vertex array support disabled (not detected - get a better driver)\n");
        dlclose(prjobj);
 }
+*/
+
+// LordHavoc: require OpenGL 1.2.x
+void VID_CheckVertexArrays (void)
+{
+       gl_arrays = true;
+}
 
 void VID_CheckMultiTexture(void) 
 {