]> de.git.xonotic.org Git - xonotic/gmqcc.git/blob - distro/arch/git/PKGBUILD
PKGBUILDs: note myself as contributor.
[xonotic/gmqcc.git] / distro / arch / git / PKGBUILD
1 # Contributor: matthiaskrgr <matthiaskrgr _strange_curverd_character_ freedroid D0T org>
2
3 pkgname=gmqcc
4 pkgver=20121226
5 pkgrel=1
6 pkgdesc="An Improved Quake C Compiler"
7 arch=('i686' 'x86_64')
8 depends=('glibc')
9 url="https://github.com/graphitemaster/gmqcc.git"
10 license=('MIT')
11
12 _gitroot="git://github.com/graphitemaster/gmqcc.git"
13 _gitname="gmqcc"
14
15 build() {
16         cd $srcdir
17         msg "Connecting to the GIT server..."
18         if [[ -d $srcdir/$_gitname ]] ; then
19                 cd $_gitname
20                 msg "Removing build files..."
21                 git clean -dfx
22                 msg "Updating..."
23                 git pull --no-tags
24                 msg "The local files are updated."
25         else
26                 msg "Cloning..."
27                 git clone $_gitroot $_gitname --depth 1
28                 msg "Clone done."
29         fi
30
31         msg "Starting compilation..."
32         cd "$srcdir"/"$_gitname"
33
34         msg "Compiling..."
35         make
36 }
37
38 check() {
39         cd "$srcdir"/"$_gitname"
40         make check
41 }
42
43 package() {
44         cd "$srcdir"/"$_gitname"
45         msg "Compiling and installing to pkgdir this time..."
46         make install DESTDIR=$pkgdir PREFIX=/usr
47         msg "Compiling done."
48
49         install -D LICENSE ${pkgdir}/usr/share/licenses/gmqcc/LICENSE
50 }