]> de.git.xonotic.org Git - xonotic/netradiant.git/blobdiff - tools/quake3/CMakeLists.txt
Merge branch 'iqmmodel' into 'master'
[xonotic/netradiant.git] / tools / quake3 / CMakeLists.txt
index adb6dc73b36e1919a2b6354c9c055e6457a6c3e8..511162a3e9433f03db0e6e216706416c9e8cb688 100644 (file)
@@ -28,6 +28,9 @@ include_directories(${LIBXML2_INCLUDE_DIR})
 find_package(ZLIB REQUIRED)
 include_directories(${ZLIB_INCLUDE_DIRS})
 
+find_package(Minizip REQUIRED)
+include_directories(${MINIZIP_INCLUDE_DIRS})
+
 set(q3map2_games
         q3map2/game_darkplaces.h
         q3map2/game_dq.h
@@ -44,6 +47,7 @@ set(q3map2_games
         q3map2/game_sof2.h
         q3map2/game_tenebrae.h
         q3map2/game_tremulous.h
+        q3map2/game_unvanquished.h
         q3map2/game_wolf.h
         q3map2/game_wolfet.h
         q3map2/game_xonotic.h
@@ -63,22 +67,28 @@ radiant_tool(q3map2
         common/scriplib.c common/scriplib.h
         common/surfaceflags.h
         common/threads.c
-        common/unzip.c common/unzip.h
         common/vfs.c common/vfs.h
 
         q3map2/brush.c
         q3map2/brush_primit.c
         q3map2/bsp.c
+        q3map2/bsp_analyze.c
+        q3map2/bsp_info.c
+        q3map2/bsp_scale.c
         q3map2/bspfile_abstract.c
         q3map2/bspfile_ibsp.c
         q3map2/bspfile_rbsp.c
         q3map2/convert_ase.c
+        q3map2/convert_bsp.c
         q3map2/convert_map.c
         q3map2/convert_obj.c
         q3map2/decals.c
+        q3map2/exportents.c
         q3map2/facebsp.c
+        q3map2/fixaas.c
         q3map2/fog.c
         ${q3map2_games} q3map2/game__null.h
+        q3map2/help.c
         q3map2/image.c
         q3map2/leakfile.c
         q3map2/light.c
@@ -89,6 +99,7 @@ radiant_tool(q3map2
         q3map2/main.c
         q3map2/map.c
         q3map2/mesh.c
+        q3map2/minimap.c
         q3map2/model.c
         q3map2/patch.c
         q3map2/path_init.c
@@ -113,6 +124,7 @@ target_link_libraries(q3map2
         ${JPEG_LIBRARIES}
         ${PNG_LIBRARIES}
         ${LIBXML2_LIBRARIES}
+        ${MINIZIP_LIBRARIES}
         ${ZLIB_LIBRARIES}
         ddslib
         etclib
@@ -131,7 +143,6 @@ radiant_tool(q3data
         common/md4.c common/md4.h
         common/scriplib.c common/scriplib.h
         common/trilib.c common/trilib.h
-        common/unzip.c common/unzip.h
         common/vfs.c common/vfs.h
 
         q3data/3dslib.c q3data/3dslib.h
@@ -149,6 +160,7 @@ radiant_tool(q3data
 target_link_libraries(q3data
         ${GLIB_LIBRARIES}
         ${LIBXML2_LIBRARIES}
+        ${MINIZIP_LIBRARIES}
         ${ZLIB_LIBRARIES}
         filematch
         etclib