]> de.git.xonotic.org Git - xonotic/netradiant.git/blobdiff - tools/quake3/CMakeLists.txt
CMake: switch minizip casing
[xonotic/netradiant.git] / tools / quake3 / CMakeLists.txt
index 3314788b4e76c093ac5cb9aebd7f6461cca2f81e..1a852983f78f68a57919d0f1d8a6072ac186170b 100644 (file)
@@ -28,6 +28,9 @@ include_directories(${LIBXML2_INCLUDE_DIR})
 find_package(ZLIB REQUIRED)
 include_directories(${ZLIB_INCLUDE_DIRS})
 
+find_package(Minizip REQUIRED)
+include_directories(${Minizip_INCLUDE_DIRS})
+
 set(q3map2_games
         q3map2/game_darkplaces.h
         q3map2/game_dq.h
@@ -44,6 +47,7 @@ set(q3map2_games
         q3map2/game_sof2.h
         q3map2/game_tenebrae.h
         q3map2/game_tremulous.h
+        q3map2/game_unvanquished.h
         q3map2/game_wolf.h
         q3map2/game_wolfet.h
         q3map2/game_xonotic.h
@@ -63,7 +67,6 @@ radiant_tool(q3map2
         common/scriplib.c common/scriplib.h
         common/surfaceflags.h
         common/threads.c
-        common/unzip.c common/unzip.h
         common/vfs.c common/vfs.h
 
         q3map2/brush.c
@@ -80,6 +83,7 @@ radiant_tool(q3map2
         q3map2/convert_map.c
         q3map2/convert_obj.c
         q3map2/decals.c
+        q3map2/exportents.c
         q3map2/facebsp.c
         q3map2/fixaas.c
         q3map2/fog.c
@@ -120,6 +124,7 @@ target_link_libraries(q3map2
         ${JPEG_LIBRARIES}
         ${PNG_LIBRARIES}
         ${LIBXML2_LIBRARIES}
+        ${Minizip_LIBRARIES}
         ${ZLIB_LIBRARIES}
         ddslib
         etclib
@@ -138,7 +143,6 @@ radiant_tool(q3data
         common/md4.c common/md4.h
         common/scriplib.c common/scriplib.h
         common/trilib.c common/trilib.h
-        common/unzip.c common/unzip.h
         common/vfs.c common/vfs.h
 
         q3data/3dslib.c q3data/3dslib.h
@@ -156,6 +160,7 @@ radiant_tool(q3data
 target_link_libraries(q3data
         ${GLIB_LIBRARIES}
         ${LIBXML2_LIBRARIES}
+        ${Minizip_LIBRARIES}
         ${ZLIB_LIBRARIES}
         filematch
         etclib